Person - Associate data can not be updated.

Overview

When trying to update a Person I get the following message in my logfile:

This line has failed with the message 'Unable to update person 'Person Name' with id 2. Associates cannot be modified.'

Cause

Associates in SuperOffice are users which consume a SuperOffice license. For these associates SuperOffice creates a so-called hash, based on the record data. When SuperOffice changes the record data a new hash will be created.

When this record data is changed by other means, like DataBridge, the hash isn't changed and does not correspondent anymore with the record data and the user will not be able to login anymore.

Solution

DataBridge will check if the person is also an Associate. If the person is an associate DataBridge will not change the Person data.